Sign in
Join now
asn1js
lapo.it
/
Star
Starred
Star
Something went wrong. Try again.
Fork
0
Eye filled
Watch
Watching
Watch
JavaScript generic ASN.1 parser (mirror)
Star
Starred
Star
Something went wrong. Try again.
Fork
Eye filled
Watch
Watching
Watch
Overview
Overview
Issues
Issues
Pulls
Pulls
Pipelines
Pipelines
Commits on
github-82
lapo.it
270561bc
Copied
Failed
Copy SHA
Rename context menu values. Add B64. Put optional one last to keep button positions.
Copy SHA
Browse repository
committed
2y ago
lapo.it
5908eadc
Copied
Failed
Copy SHA
Avoid inline javascript. (for future usage with CSP header)
Copy SHA
Browse repository
committed
2y ago
lapo.it
4a03d932
Copied
Failed
Copy SHA
Refactor context menu to use existing methods. (and avoid re-parsing parsed data)
Copy SHA
Browse repository
committed
2y ago
lapo.it
fe04d974
Copied
Failed
Copy SHA
Use blocks instead of `<br>` in context menu.
Copy SHA
Browse repository
committed
2y ago
lapo.it
0eb4fcf7
Copied
Failed
Copy SHA
Improve hex dump capabilities of ASN.1 nodes.
Copy SHA
Browse repository
committed
2y ago
lapo.it
3291c101
Copied
Failed
Copy SHA
File forgot in previous (refactor) commit.
Copy SHA
Browse repository
committed
2y ago
lapo.it
0c2dc0c1
Copied
Failed
Copy SHA
Refactor contextual menu in a different module.
Copy SHA
Browse repository
committed
2y ago
lapo.it
c2ebbf44
Copied
Failed
Copy SHA
propagate from branch 'it.lapo.asn1js.esm' (head 1f81e568f0723f8ce942b435f81d205e157789ce) to branch 'it.lapo.asn1js.github-82' (head 7107a48abf688173dcdf7bd716d415c8edd85f46)
Copy SHA
Browse repository
committed
2y ago
lapo.it
e3fca65c
Copied
Failed
Copy SHA
Update credits.
Copy SHA
Browse repository
committed
2y ago
lapo.it
be8d97ae
Copied
Failed
Copy SHA
propagate from branch 'it.lapo.asn1js' (head dd18afd1c4344811526fc928f3975fe414584018) to branch 'it.lapo.asn1js.github-82' (head 27ed876d23a39e4ec2bfd2f6233f38610720add2)
Copy SHA
Browse repository
committed
2y ago
lapo.it
1fcc683e
Copied
Failed
Copy SHA
Force examples permissions.
Copy SHA
Browse repository
committed
2y ago
lapo.it
aa1f1c31
Copied
Failed
Copy SHA
propagate from branch 'it.lapo.asn1js' (head 741a5e9cfd4ef4e45f1e5b505e02c4142e82dd8d) to branch 'it.lapo.asn1js.esm' (head 4d3ff39de9922b95cbd11c2534c9188ff1db72f0)
Copy SHA
Browse repository
committed
2y ago
lapo.it
2654e9cd
Copied
Failed
Copy SHA
Add very basic PKCS#1 support and RSA key examples.
Copy SHA
Browse repository
committed
2y ago
lapo.it
5027c72b
Copied
Failed
Copy SHA
propagate from branch 'it.lapo.asn1js' (head a9524436000d6561058ba0ae8e2a58a6c49837fd) to branch 'it.lapo.asn1js.esm' (head a6b77044e2cf0f91cb663d9d1fbfbca7f66c2d21)
Copy SHA
Browse repository
committed
2y ago
lapo.it
8f048acc
Copied
Failed
Copy SHA
When trying to parse encapsulated values, check that the content can be parsed as well.
Copy SHA
Browse repository
committed
2y ago
lapo.it
405c0361
Copied
Failed
Copy SHA
Drop dead code.
Copy SHA
Browse repository
committed
2y ago
lapo.it
7a51b8a0
Copied
Failed
Copy SHA
Fix tests.
Copy SHA
Browse repository
committed
2y ago
lapo.it
26d3a722
Copied
Failed
Copy SHA
Throw exceptions, not strings.
Copy SHA
Browse repository
committed
2y ago
lapo.it
9ff23e14
Copied
Failed
Copy SHA
Use HTTPS links.
Copy SHA
Browse repository
committed
2y ago
lapo.it
c894e6a3
Copied
Failed
Copy SHA
Index only needs to import a single module.
Copy SHA
Browse repository
committed
2y ago
lapo.it
86639243
Copied
Failed
Copy SHA
Version 2.0.1.
2.0.1
Copy SHA
Browse repository
committed
2y ago
lapo.it
70426d25
Copied
Failed
Copy SHA
Update tags.
Copy SHA
Browse repository
committed
2y ago
lapo.it
65c222d4
Copied
Failed
Copy SHA
Update browser support warnings.
Copy SHA
Browse repository
committed
2y ago
lapo.it
b7f47f60
Copied
Failed
Copy SHA
Improve README.
Copy SHA
Browse repository
committed
2y ago
lapo.it
f220f663
Copied
Failed
Copy SHA
propagate from branch 'it.lapo.asn1js' (head 263fa0cb3936ec99c2be2c51a2265cadfbded687) to branch 'it.lapo.asn1js.esm' (head c360c489896f2e9ec2c280e6d55b03a0581252c2)
Copy SHA
Browse repository
committed
2y ago
lapo.it
690364a6
Copied
Failed
Copy SHA
Improve type matching.
Copy SHA
Browse repository
committed
2y ago
lapo.it
ae4458e8
Copied
Failed
Copy SHA
Update example usage.
Copy SHA
Browse repository
committed
2y ago
lapo.it
1b3078e4
Copied
Failed
Copy SHA
Version 2.0.0 in order to signal this is a breaking change.
2.0.0
Copy SHA
Browse repository
committed
2y ago
lapo.it
ae7ee7bd
Copied
Failed
Copy SHA
Unbreak tests.
Copy SHA
Browse repository
committed
2y ago
lapo.it
72c71f13
Copied
Failed
Copy SHA
Update copyright.
Copy SHA
Browse repository
committed
2y ago
lapo.it
c1f4dff6
Copied
Failed
Copy SHA
Convert to ES6 Modules (ESM).
1.3.0
Copy SHA
Browse repository
committed
2y ago
Oliver Burgmaier
429f7526
Copied
Failed
Copy SHA
Indention fixed
Copy SHA
Browse repository
committed
2y ago
Oliver Burgmaier
1d7f90b1
Copied
Failed
Copy SHA
Fix: Show context menu at correct position
Copy SHA
Browse repository
committed
2y ago
Oliver Burgmaier
e6dbc080
Copied
Failed
Copy SHA
Negative list for set and sequence
Copy SHA
Browse repository
committed
2y ago
Oliver Burgmaier
dcf1b13e
Copied
Failed
Copy SHA
New: Align context menu to left
Copy SHA
Browse repository
committed
2y ago
Oliver Burgmaier
af5e9e7c
Copied
Failed
Copy SHA
New: Copy as pretty
Copy SHA
Browse repository
committed
2y ago
Oliver Burgmaier
d5465fce
Copied
Failed
Copy SHA
Fix: Copy the string to clipboard
Copy SHA
Browse repository
committed
2y ago
Oliver Burgmaier
e7d2bfdb
Copied
Failed
Copy SHA
Context menu initially hidden
Copy SHA
Browse repository
committed
2y ago
Oliver Burgmaier
17dd53a9
Copied
Failed
Copy SHA
Context menu and copyAsString added
Copy SHA
Browse repository
committed
2y ago
Oliver Burgmaier
c7cf816e
Copied
Failed
Copy SHA
hex copy on click
Copy SHA
Browse repository
committed
2y ago
lapo.it
7c2a63b4
Copied
Failed
Copy SHA
Update `eslint` rules a bit.
Copy SHA
Browse repository
committed
3y ago
lapo.it
408efbc4
Copied
Failed
Copy SHA
Favicon fixes.
Copy SHA
Browse repository
committed
3y ago
lapo.it
1e9e5d72
Copied
Failed
Copy SHA
Add SVG favicon. It is supported by all except Safari as of today: https://caniuse.com/link-icon-svg
Copy SHA
Browse repository
committed
3y ago
lapo.it
e1751b95
Copied
Failed
Copy SHA
Fix ignore files.
Copy SHA
Browse repository
committed
3y ago
lapo.it
b015f480
Copied
Failed
Copy SHA
Commit data parsed from ASN.1 definitions as found in RFCs. I think this is allowed under the following clause: It is acceptable under the current IETF rules (RFC 5378) to modify extracted code if necessary. https://trustee.ietf.org/about/faq/#reproducing-rfcs
Copy SHA
Browse repository
committed
3y ago
lapo.it
81658dff
Copied
Failed
Copy SHA
Update ignore files.
Copy SHA
Browse repository
committed
3y ago
lapo.it
fd3c4068
Copied
Failed
Copy SHA
Fix CMPv2 example encoding.
rfc4210
Copy SHA
Browse repository
committed
3y ago
lapo.it
0f4144d1
Copied
Failed
Copy SHA
Serve local folder, as most browsers don't allow CORS on `file:`.
Copy SHA
Browse repository
committed
3y ago
lapo.it
907e6248
Copied
Failed
Copy SHA
Import RFC 4211 as a requisite for RFC 4210.
Copy SHA
Browse repository
committed
3y ago
lapo.it
d7926ad3
Copied
Failed
Copy SHA
Add CMPv2 example as found on Wireshark page.
Copy SHA
Browse repository
committed
3y ago
lapo.it
d143a359
Copied
Failed
Copy SHA
Add RFC 4210 support. (work in progress)
Copy SHA
Browse repository
committed
3y ago
lapo.it
3585e314
Copied
Failed
Copy SHA
Drop buffer support, as this parser is always used on modified strings.
Copy SHA
Browse repository
committed
3y ago
lapo.it
bfbf9ed7
Copied
Failed
Copy SHA
Print line/column in parse excceptions.
Copy SHA
Browse repository
committed
3y ago
lapo.it
1e0b0564
Copied
Failed
Copy SHA
README credits.
github-64
Copy SHA
Browse repository
committed
3y ago
lapo.it
b0ca46e7
Copied
Failed
Copy SHA
propagate from branch 'it.lapo.asn1js' (head fdc7e1256b4ba407c342491f6289f65f6b92b39a) to branch 'it.lapo.asn1js.github-64' (head 60152e052bc4534a2f32aa68c6880abfe6d2649b)
Copy SHA
Browse repository
committed
3y ago
lapo.it
e66a38d2
Copied
Failed
Copy SHA
Fix lint error.
Copy SHA
Browse repository
committed
3y ago
lapo.it
b7d379bb
Copied
Failed
Copy SHA
Add PKCS#10 example.
Copy SHA
Browse repository
committed
3y ago
lapo.it
d4d7a7ce
Copied
Failed
Copy SHA
merge of '2f0c2df3d511db7c2bf4746f105fe4c2e5f896f7' and '57ba84202811cac02d8e175501a4fdb5758ba10a'
Copy SHA
Browse repository
committed
3y ago
lapo.it
c9324b2c
Copied
Failed
Copy SHA
Add type support for PKCS#10 certification requests.
Copy SHA
Browse repository
committed
3y ago
lapo.it
3a2ce636
Copied
Failed
Copy SHA
Do not fail on missing types. (un-break example `letsencrypt-x3.cer`)
Copy SHA
Browse repository
committed
3y ago
Previous
1
2
3
4
5
…
8
Next