Sign in
Join now
asn1js
lapo.it
/
Star
Starred
Star
Something went wrong. Try again.
Fork
0
Eye filled
Watch
Watching
Watch
JavaScript generic ASN.1 parser (mirror)
Star
Starred
Star
Something went wrong. Try again.
Fork
Eye filled
Watch
Watching
Watch
Overview
Overview
Issues
Issues
Pulls
Pulls
Pipelines
Pipelines
Commits on
github-56
lapo.it
f5ba2805
Copied
Failed
Copy SHA
propagate from branch 'it.lapo.asn1js' (head 783aeee59d0efbf58eae2b67ccfff2c7bd69728e) to branch 'it.lapo.asn1js.github-56' (head 5bdc685e5b3dfc07a032cc3ecf417d88e004443a)
Copy SHA
Browse repository
committed
3y ago
lapo.it
1f2bfbb3
Copied
Failed
Copy SHA
Add proper credits. Closes #56 on GitHub.
Copy SHA
Browse repository
committed
3y ago
lapo.it
fb78e972
Copied
Failed
Copy SHA
Use underscores like other types.
Copy SHA
Browse repository
committed
3y ago
lapo.it
1c16cff2
Copied
Failed
Copy SHA
Add new shortcut methos which I find more readable.
Copy SHA
Browse repository
committed
3y ago
lapo.it
1fb6f67f
Copied
Failed
Copy SHA
First value of relative OIDs is normal, does not encode two arcs.
Copy SHA
Browse repository
committed
3y ago
lapo.it
a0beae2c
Copied
Failed
Copy SHA
Create new section for relative OIDs tests. Add (failing) test from official documentation.
Copy SHA
Browse repository
committed
3y ago
Mistial Developer
83e8d76d
Copied
Failed
Copy SHA
Add relative OID support
Copy SHA
Browse repository
committed
3y ago
lapo.it
24d9234f
Copied
Failed
Copy SHA
Complete support for `ContentInfo`.
Copy SHA
Browse repository
committed
3y ago
lapo.it
7334473b
Copied
Failed
Copy SHA
Correctly use module default implicit/explicit setting.
Copy SHA
Browse repository
committed
3y ago
lapo.it
c29661d4
Copied
Failed
Copy SHA
Add somewhat support for `ContentInfo`.
Copy SHA
Browse repository
committed
3y ago
lapo.it
398defae
Copied
Failed
Copy SHA
More generic type searching. Still working with `Certificate`.
Copy SHA
Browse repository
committed
4y ago
lapo.it
2c896a85
Copied
Failed
Copy SHA
Add enough `SEQUENCE` logic to correctly decode `examples/ed25519.cer`.
Copy SHA
Browse repository
committed
4y ago
lapo.it
c486756b
Copied
Failed
Copy SHA
Type ys yellow, let's color identifier name in blue.
Copy SHA
Browse repository
committed
4y ago
lapo.it
4e18b23f
Copied
Failed
Copy SHA
Fix timezone parsing. Closes #54 on GitHub.
Copy SHA
Browse repository
committed
4y ago
lapo.it
b13d6cd8
Copied
Failed
Copy SHA
Change license wording so that it can be automatically recognized.
Copy SHA
Browse repository
committed
4y ago
lapo.it
733b4338
Copied
Failed
Copy SHA
Avoid defining constants on each cycle.
Copy SHA
Browse repository
committed
4y ago
lapo.it
a3de0f18
Copied
Failed
Copy SHA
Fix syntax.
Copy SHA
Browse repository
committed
4y ago
lapo.it
16b24394
Copied
Failed
Copy SHA
Add preliminary support for T.61.
Copy SHA
Browse repository
committed
4y ago
lapo.it
330eafc6
Copied
Failed
Copy SHA
Add missing parameter. H/t: eslint.
Copy SHA
Browse repository
committed
4y ago
lapo.it
1017014c
Copied
Failed
Copy SHA
Add support for constructed strings. Warning: `Stream.parseString*()` methods now return a `{ size, str }` object instead of only `str`.
Copy SHA
Browse repository
committed
4y ago
lapo.it
cc016bdb
Copied
Failed
Copy SHA
Add some more tests from RSA labs ASN.1 primer. Add "expected failures". Only show errors unless "all" command line parameter is specified.
Copy SHA
Browse repository
committed
4y ago
lapo.it
93da1d45
Copied
Failed
Copy SHA
Fix base branch (`trunk` instead of `master`).
Copy SHA
Browse repository
committed
4y ago
lapo.it
00122a44
Copied
Failed
Copy SHA
Improve git export with automatic creation and update of authors and branches file.
Copy SHA
Browse repository
committed
4y ago
lapo.it
810b53ba
Copied
Failed
Copy SHA
merge of '17bac5d40572cbeba1c86eae1f5c8b55616e3bb4' and 'f35d0ac8f2a3b09b30f9f18348137c796337de68'
Copy SHA
Browse repository
committed
4y ago
lapo.it
a7d63f1a
Copied
Failed
Copy SHA
Update copyright year.
Copy SHA
Browse repository
committed
4y ago
lapo.it
803cd7a8
Copied
Failed
Copy SHA
Fix DER/BER parsing.
Copy SHA
Browse repository
committed
4y ago
lapo.it
dbd4ab68
Copied
Failed
Copy SHA
Parametrize parsed file too.
Copy SHA
Browse repository
committed
4y ago
lapo.it
aaea7653
Copied
Failed
Copy SHA
Update all repositories every time.
Copy SHA
Browse repository
committed
4y ago
lapo.it
cf9b9c24
Copied
Failed
Copy SHA
Parse PEMs from file. ESLint fixes.
Copy SHA
Browse repository
committed
4y ago
lapo.it
8faf4c6c
Copied
Failed
Copy SHA
Update ecmaScript version to allow optional chaining.
Copy SHA
Browse repository
committed
4y ago
lapo.it
96c61de8
Copied
Failed
Copy SHA
Download RFCs in a subdirectory.
Copy SHA
Browse repository
committed
4y ago
lapo.it
09855f35
Copied
Failed
Copy SHA
Add script to download and parse automatically a few RFCs.
Copy SHA
Browse repository
committed
4y ago
lapo.it
13e2552b
Copied
Failed
Copy SHA
ESLint.
Copy SHA
Browse repository
committed
4y ago
lapo.it
00b506d2
Copied
Failed
Copy SHA
Add local dump capable of matching ASN.1 content and definition.
Copy SHA
Browse repository
committed
4y ago
lapo.it
a21413b6
Copied
Failed
Copy SHA
ESLint using ES6 for NodeJS scripts.
Copy SHA
Browse repository
committed
4y ago
lapo.it
22754c21
Copied
Failed
Copy SHA
Use same-level `id` instead of enclosed `name` with mixed meaning.
Copy SHA
Browse repository
committed
4y ago
lapo.it
0ccdbecd
Copied
Failed
Copy SHA
First version of an ASN.1 parser. It is capable of reading most of RFC5280, RFC3369, RFC3161.
Copy SHA
Browse repository
committed
4y ago
lapo.it
8ca85b61
Copied
Failed
Copy SHA
Use let/const in test program. NodeJS v.6.0.0 supports it since 2016-04-26, that's pretty enough wait for a test suite.
Copy SHA
Browse repository
committed
4y ago
lapo.it
1bef1781
Copied
Failed
Copy SHA
Update copyright year.
Copy SHA
Browse repository
committed
5y ago
lapo.it
aed8224e
Copied
Failed
Copy SHA
Version 1.2.3.
1.2.3
Copy SHA
Browse repository
committed
5y ago
lapo.it
2d18df7c
Copied
Failed
Copy SHA
Update copyright year.
Copy SHA
Browse repository
committed
5y ago
lapo.it
b9468f8e
Copied
Failed
Copy SHA
Closes #34 on GitHub.
Copy SHA
Browse repository
committed
5y ago
lapo.it
75c86dca
Copied
Failed
Copy SHA
Support raw b64 files too.
Copy SHA
Browse repository
committed
5y ago
lapo.it
383db01f
Copied
Failed
Copy SHA
Sync with latest changes from Peter Gutmann's website.
Copy SHA
Browse repository
committed
5y ago
lapo.it
caa4cf98
Copied
Failed
Copy SHA
Version 1.2.2.
1.2.2
Copy SHA
Browse repository
committed
5y ago
lapo.it
76b16713
Copied
Failed
Copy SHA
Work-around for IE8 with closed developer tools.
Copy SHA
Browse repository
committed
5y ago
lapo.it
8fff4c2c
Copied
Failed
Copy SHA
Fix linting.
Copy SHA
Browse repository
committed
5y ago
lapo.it
c5a753f1
Copied
Failed
Copy SHA
Only recurse if constructed, not encapsulated. Closes #47 on GitHub.
Copy SHA
Browse repository
committed
5y ago
lapo.it
ba7643fb
Copied
Failed
Copy SHA
Test GitHub issue #47.
Copy SHA
Browse repository
committed
5y ago
lapo.it
fd139950
Copied
Failed
Copy SHA
Forgot in previous commit.
Copy SHA
Browse repository
committed
6y ago
lapo.it
2f303efe
Copied
Failed
Copy SHA
Add two example attached signatures (using recent crypto).
Copy SHA
Browse repository
committed
6y ago
lapo.it
40b7e8b6
Copied
Failed
Copy SHA
Use Unpkg for RequireJS too. (a single CDN is better than two, also URL is shorter)
Copy SHA
Browse repository
committed
6y ago
lapo.it
f25604a7
Copied
Failed
Copy SHA
Add RequireJS example usage.
Copy SHA
Browse repository
committed
6y ago
lapo.it
652ca1fd
Copied
Failed
Copy SHA
Version 1.2.1.
1.2.1
Copy SHA
Browse repository
committed
6y ago
lapo.it
f72860f5
Copied
Failed
Copy SHA
Accept `\t\r\n` when detecting printable strings.
Copy SHA
Browse repository
committed
6y ago
lapo.it
a215129a
Copied
Failed
Copy SHA
We need the './' also in the AMD case, not only for Node. Closes #44 on GitHub.
Copy SHA
Browse repository
committed
6y ago
lapo.it
99b74e0e
Copied
Failed
Copy SHA
Complete command line example.
Copy SHA
Browse repository
committed
6y ago
lapo.it
edf1ac4a
Copied
Failed
Copy SHA
Add new example certificate using ed25519.
Copy SHA
Browse repository
committed
6y ago
lapo.it
18538022
Copied
Failed
Copy SHA
Keep files with Unix line endings.
Copy SHA
Browse repository
committed
6y ago
lapo.it
699d15aa
Copied
Failed
Copy SHA
Keep examples in separate PEM encoded files (which allows for comments).
Copy SHA
Browse repository
committed
6y ago
Previous
1
2
3
4
5
6
Next